Discussion:
you got it!
(too old to reply)
w***@gmail.com
2017-06-24 19:21:34 UTC
Permalink
i don't know when it happened but i've noticed that i don't have a thread
hanging around when i quite FG in gdb... i don't think that it had anything to
do with gdb but it certainly showed it to me...

as near as i can tell, an update from the repo applied here between the 15th and
the 19th fixed it... the below looks great and the "inferior" process line is
now above the quit command with a proper exit instead of below it asking if we
want to force it down and waiting with another y/n prompt...

[GOOD]
[Thread 0x7fffb6027700 (LWP 29056) exited]
[Thread 0x7fffb802b700 (LWP 29051) exited]
[Thread 0x7fffb782a700 (LWP 29053) exited]
[Thread 0x7fffb7029700 (LWP 29054) exited]
[Thread 0x7fffb6828700 (LWP 29055) exited]
[Thread 0x7fffe87a3700 (LWP 29061) exited]
[New Thread 0x7fffe87a3700 (LWP 382)]
[Thread 0x7fffe4d20700 (LWP 28610) exited]
[Thread 0x7fffb8c50700 (LWP 29050) exited]
[Thread 0x7fffe87a3700 (LWP 382) exited]
[Thread 0x7fff9a3fa700 (LWP 12850) exited]
[Thread 0x7fffba2ab700 (LWP 29171) exited]
[Inferior 1 (process 28596) exited normally]
(gdb) quit

** End Date: 2017-06-24 15:09:54 **
** Total Elapsed Time: 0 days 8 hours 48 minutes 53 seconds **
--
NOTE: No off-list assistance is given without prior approval.
*Please keep mailing list traffic on the list unless*
*a signed and pre-paid contract is in effect with us.*
James Turner
2017-06-25 09:54:20 UTC
Permalink
as near as i can tell, an update from the repo applied here between the 15th and the 19th fixed it
I made some changes a few weeks ago that I hoped would fix this, so this sounds promising!

Kind regards,
James
w***@gmail.com
2017-06-25 11:45:14 UTC
Permalink
Post by James Turner
Post by w***@gmail.com
as near as i can tell, an update from the repo applied here between the 15th
and the 19th fixed it
I made some changes a few weeks ago that I hoped would fix this, so this sounds promising!
yeah, i had to wait a bit on updating because of not being able to compile with
the new code needing Qt 5.4 components that don't exist here... i did try but
with the FG compile failing, i was stuck with its old binary... so yeah, it was
probably earlier than that that it was fixed... in any case, that's one less
"grrr" for me ;) ;) ;)
--
NOTE: No off-list assistance is given without prior approval.
*Please keep mailing list traffic on the list unless*
*a signed and pre-paid contract is in effect with us.*
Loading...